Rotary Engine Illustrated Community
This site endeavors to be the best resource on the internet for educational material on the Rotary Engine.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

12A running but being held back

 
Post new topic   Reply to topic    Rotary Engine Illustrated Community Forum Index -> Troubleshooting
View previous topic :: View next topic  
Author Message
drdish



Joined: 19 Aug 2007
Posts: 1

PostPosted: Sun Aug 19, 2007 9:57 am    Post subject: 12A running but being held back Reply with quote

Hello All-
First post to this site. I have a 1984 GSL with a 12A engine. Bought it non running. I have corrected and tested a lot of issues, such as getting the plug wires in the correct locations, (they were set opposite each other originally). The gas tank was totally bone dry and it's tags had expired 4 years ago, so it has been sitting a long time. I have "nursed" it back to life and have it running and driving. My problem is it feels like it is is being held back, reving it up takes a little effort as it will rev up, it does it slower than it should. There is also a sort of whining noise, that progressively winds up with the engine. Any help or guidance on what to check next would be greatly appriciated. Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Rotary Engine Illustrated Community Forum Index -> Troubleshooting All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group